Creating & Editing

This is where it gets interesting! Learn how to create and edit images using Rainbow Painter.

Picture Operations

Found in the Picture menu in the Menu Bar Panel, this is a list of operations that affect the whole picture with all of its layers.
Some of the operations are: Duplicate, Scale, Crop.
A few related operations like New Picture, Destroy Picture, Import/Export Picture can be found in the File menu.

Layer Operations

Found in the Layer menu in the Menu Bar Panel, this is a list of operations that affect the current layer or create a new one.
Some of the operations are: New, Duplicate, Destroy.

Effects

In the Effects menu in the Menu Bar Panel you will find several effects to choose from.
Please note that the effects will be applied to the current layer only.
Some of the effects are: Gaussian Blur, Contrast, Tropical Splash.

Selection

Use one of the 'Selection Tools' in the Tools menu in the Menu Bar Panel, to fence in an area.
When you draw/paint or apply effects, only the selected area will be affected, until you switch off the selection by unchecking the check box next to 'Selection' in the Edit menu.

Before you create a selection with one of the 'soft' selection tools, don't forget to first adjust the tool's 'Softness' setting to decide how soft/blurred the edges should be when the selection is later used.

In the Edit menu under 'Selection Modifiers', you will find some operations to adjust and manipulate (e.g. invert, grow, shrink) the selection.
You will also find some alternate ways of creating selections under 'Selection Creators' (e.g. Splash).


In the Tool Settings panel, below the other settings and colors, you are able to choose from four different modes that decide how the selection tool will work.

The default mode is Replace, which is the button with a '!' on it, that makes the new selection you create replace any old ones that may exist.

The mode Add (the '+' button) tells the selection tool to keep any old selections in addition to the new one.

The mode Subtract (the '-' button) lets you use the selection tool to remove parts of an existing selection, e.g. if you want to turn a circle-shaped selection into a donut.

Finally, there's a mode button with a '&' on it. When you make a new selection, this mode compares any existing selection with the new one and keeps selected only the areas that were covered by both the old and the new selection (hence the '&' on the button).

Repeating & Seamless Tiles

A seamless tile/pattern is an image made especially with the purpose of being viewed repeated (side by side) without any seams or edges showing, making it look like one continuous picture.
This type of image can, for example, be used for 3D modeling and video games or as backgrounds on websites and computer desktops.

Everyone who's ever struggled trying to create seamless tiles, will absolutely love Rainbow Painter's repeat feature, since it completely makes the (in)famous Offset Filter obsolete!

If you check the 'X-Repeat Pic' and/or 'Y-Repeat Pic' check boxes (found in the View menu in the Menu Bar Panel), the picture you're working on will be displayed repeated horizontally and/or vertically.
The best thing is that all tools and effects work unrestricted and you can draw anywhere on the repeated pattern, even over the seams/edges, in true WYSIWYG (What-You-See-Is-What-You-Get) style!

Drawing/Painting

All drawing/painting is done in the picture editor window in the center, using either the left or the right mouse button.

In the Tools menu in the Menu Bar Panel, choosing a tool will assign that tool to the button you used when you clicked.

On the lower left side of the screen is the Tool Settings panel, containing all tool related settings (e.g. color, size, strength etc).
Each setting works in two possible ways:
It's either split in two, one for the left mouse button and one for the right, or it covers both buttons.
Right-click on the setting to toggle the split mode and left-click to adjust it.

This way, for example, you can have the mouse buttons share the same tool and size but have different strength and color.
The possibilities are endless! Well, maybe not endless, but it's still a very cool feature...


Normally you choose a paint color by left- or right-clicking on a palette.
Some tools however, need you to choose extra colors (e.g. inner/outer edge colors
or a highlight color), which is done by left- or right-clicking on that
extra color thus dropping the current paint color onto it.

Undo & Savepoint

Found in the Edit menu in the Menu Bar Panel, both undo and redo work as you'd expect them to.

The savepoint function lets you set a savepoint that you can revert to later if needed.

Go to the Edit menu and choose 'Create Savepoint' when you're happy with how the picture currently looks, before you start adding something you feel _might_ ruin it.
If you then realize you've messed things up, just undo everything by going back to the savepoint!